Laravel 项目中的php命令行The openssl extension is required for SSL/TLS

Laravel笔记 格尔格西船长 1765℃ 0评论

使用composer安装laravel项目的时候,发现报错The openssl extension is required for SSL/TLS protection but is not available。

出现这样的错误,是由于没有开启php的openssl扩展。但是在浏览器中输出phpinfo信息,发现openssl已经开启。但在命令行就不行。

后来在命令行

php -i | grep ‘php.ini’

发现,php加载的配置和wamp里面的加载不一样,显示在C:/Windows下,在该目录下并每找到php.ini文件,于是复制php安装目录下的php.ini到C:/Windows目录下。

再去执行composer的命令就没有这样的错误啦

转载请注明:IT狂客网 » Laravel 项目中的php命令行The openssl extension is required for SSL/TLS

喜欢 (3)or分享 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

狂客者,狂而克之谓也!

联系我们